Parcourir la source

Only support Python 3.6

Yeah, I don't feel like setting up multiple Pythons for Pocketsphinx and
making a real test suite to ensure everything is working for 3.5.  I'm
planning on using provisional APIs (specifically the `typing` module) so
I won't make any claim to support any version of Python other than the
one I'm developing with.
Clara Hobbs il y a 5 ans
Parent
révision
6cd033558a
2 fichiers modifiés avec 2 ajouts et 2 suppressions
  1. 1
    1
      README.rst
  2. 1
    1
      setup.py

+ 1
- 1
README.rst Voir le fichier

@@ -23,7 +23,7 @@ is to check out the Git repository and run it from there::
23 23
 Dependencies
24 24
 ~~~~~~~~~~~~
25 25
 
26
-1. Python 3 (tested with 3.5, may work with older versions)
26
+1. Python 3.6
27 27
 2. pocketsphinx 5prealpha
28 28
 3. gstreamer-1.0 (and what ever plugin has pocketsphinx support)
29 29
 4. gstreamer-1.0 base plugins (required for ALSA)

+ 1
- 1
setup.py Voir le fichier

@@ -22,7 +22,7 @@ setup(
22 22
             "(GPLv3+)",
23 23
         "Operating System :: POSIX :: Linux",
24 24
         "Programming Language :: Python :: 3 :: Only",
25
-        "Programming Language :: Python :: 3.5",
25
+        "Programming Language :: Python :: 3.6",
26 26
         "Topic :: Home Automation"
27 27
     ],
28 28
     install_requires=["requests", "setuptools"],

Chargement…
Annuler
Enregistrer